PDA

View Full Version : AntiAimCheat UT Linux Crash



~V~
06-07-2013, 04:33 AM
It looks like the sound is in the wrong format:

appError called:
Invalid sound format in Sound AntiAimCheat.Negative
Executing UObject::StaticShutdownAfterError
Executing USDLClient::ShutdownAfterError
UALAudioSubsystem::ShutdownAfterError
Executing USDLViewport::ShutdownAfterError
UOpenGLRenderDevice::ShutdownAfterError
Signal: SIGSEGV [segmentation fault]

I checked and the sound is in mp3 format. Looks like it may be a bitrate problem. Or perhaps Linux UT doesn't support mp3.

Any chance of fixing it with a .wav please?

Crsk
06-07-2013, 06:02 AM
mp3? weird

what i did was change it from mp3 to wav (22050k and mono) then from wav to uax then load it in the class using #exec OBJ LOAD FILE="Audio\Negative.uax" PACKAGE=AntiAimCheat

I'll make sure it has the correct properties then import directly as wav this time.

with #exec AUDIO IMPORT NAME="Negative" FILE=SOUNDS\Negative.wav GROUP="Robot"

i'll post the v2 adding AntiMouseLook support in here, thanks V for reporting, sam told about this linux issue some days ago but i didn't listen xD

:ape:

~V~
06-07-2013, 08:03 AM
I exported it with Wotgreal Exporter and tried playing it as a wav. All I got was white noise. So I ran 'file' on it and came back as mp3. Plays in my mp3 player just fine.

Edit: Just tried exporting it with UnrealEd and that also produces an mp3:

file Negative.wav
Negative.wav: MPEG ADTS, layer III, v1, 128 kbps, 44.1 kHz, JntStereo

Crsk
06-07-2013, 08:37 AM
ok the problem is the output rate, i'll fix this night, thanks

Crsk
06-07-2013, 09:26 AM
according your last post, it's the stereo too, maybe was my converter or maybe I picked up the wrong file before import :shame:
:ape:

btw ~V~ I want to ask you something, going you to release the xnukers someday? gonna be only for admins - mods or to everyone as spectator?

i'm waiting :D

it's a XConsole extension or it's a new version?

~V~
06-07-2013, 09:31 AM
You know, I wouldn't be surprised if Linux UT just doesn't support mp3 because you need a license to decode mp3 afiak, and I can't imagine Loki Games getting one..

The nukers thing is part of XConsole and it will be released in probably the next two weeks. I had to take some time away from coding to do some Uni stuff but now I'll get back into it and see what bugs need fixing (when I can get on the server that is) ;)

Crsk
06-07-2013, 09:57 AM
You know, I wouldn't be surprised if Linux UT just doesn't support mp3 because you need a license to decode mp3 afiak, and I can't imagine Loki Games getting one..
as far as I know UT or UT Linux does not support mp3 but Unreal 1 does (newer patches), also supports stereo and higher output rates... damn, it's older and a lot better

SAM
06-07-2013, 12:18 PM
Does it really need to have a sound in it ? Just take it out since the sound doesn't really serve a purpose

Crsk
06-08-2013, 02:23 AM
Does it really need to have a sound in it ? Just take it out since the sound doesn't really serve a purpose
in your dreams.

Download > > AntiAimCheatV1.2 (http://www.mediafire.com/?0431ptpa2bwnrpa)

here is v1.2 comes with .ini and with anti mouse's Y axis cheat.

in my first post here i said i'll add AntiMouseLook support... ehraajw wrong, v1.1 already have it, i was trying to say Yaxis cheat support (I was sleepy -.-), ok it is already added but i'm almost sure that i did wrong, idk how to check the axis so i let the mutator remove/reset the player's mouse aceleration using tick(), i'm sure it's a noob way but works, i hope this method is not performance dangerous.

when the player joins the server he may see a message saying:
"AntiAimCheat has removed extra mouse acceleration for your sake"
"reconfigure mouse sensitivity under Preferences > Input if needed."

actually is needed to write a simple bind in the console to use the Y axis cheat (with the old anticv and also with AntiAimCheatv1.1)

~V~ can you try to produce the crash from linux in v1.2 and tell me please? should be fixed

~V~
06-08-2013, 03:44 AM
I tried it on my LAN server and it no longer crashes. Many thanks.

Crsk: I just tried to send you a PM and your inbox is full. Need to ask you some details...

~V~
06-08-2013, 04:02 AM
Crsk: I can't actually get it to work. I tried turning mouse look off and bound Enter to CenterView and it doesn't seem to affect anything. I'm using the defaults:


[AntiAimCheatV1_2.AntiAimCheat]
bShowStartMessage=True
bCVWarnBeforeKick=True
bMLWarnBeforeKick=True
cvSayWhenKicked="I was trying to use CenterView and I got caught :'<"
mlSayWhenKicked="I was trying to disable Mouselook and I got caught :'<"
cvSayWhenCaught="TRYING TO CENTERVIEW (AntiAimCheat Message)"
mlSayWhenCaught="TRYING TO DISABLE MOUSELOOK (AntiAimCheat Message)"

Any ideas? It does show as loaded in the server log.

Crsk
06-08-2013, 04:29 AM
Crsk: I can't actually get it to work. I tried turning mouse look off and bound Enter to CenterView and it doesn't seem to affect anything. I'm using the defaults:

Code:
[AntiAimCheatV1_2.AntiAimCheat]
bShowStartMessage=True
bCVWarnBeforeKick=True
bMLWarnBeforeKick=True
cvSayWhenKicked="I was trying to use CenterView and I got caught :'<"
mlSayWhenKicked="I was trying to disable Mouselook and I got caught :'<"
cvSayWhenCaught="TRYING TO CENTERVIEW (AntiAimCheat Message)"
mlSayWhenCaught="TRYING TO DISABLE MOUSELOOK (AntiAimCheat Message)"
Any ideas? It does show as loaded in the server log.

add ServerPackages=AntiAimCheatV1_2 under your server's [Engine.GameEngine] (from UnrealTournament.ini)
then clients will be affected

~V~
06-08-2013, 04:32 AM
Yes I already have that

Crsk
06-08-2013, 04:34 AM
mm idk then, i'll check it

~V~
06-08-2013, 04:36 AM
This is what is in the client log:

PendingLevel received: USES GUID=A9E210B2463EF55CD0360B8C98968F7D PKG=AntiAimCheatV1_2 FLAGS=1 SIZE=37693 GEN=1 FNAME=AntiAimCheatV1_2.u

Crsk
06-08-2013, 04:44 AM
guess it is because you shouldn't be a local player, the mutator is not working on Level.NetMode == NM_Client, try a dedicated server then join as non local client

~V~
06-08-2013, 04:50 AM
I'm not a local player. I have my server running on a separate box:

./ucc-bin server CTF-Thorns?Game=Botpack.CTFGame?Mutator=AntiAimCheatV1 _2.AntiAimCheat multihome=192.168.1.2 ini=server.ini log=server.tmp

I also tried putting it in as ServerActors= but same problem.

--- Updated ---

Server log:

InitGame: ?Name=bla?Class=BotPack.TFemale2?team=0?skin=SGirl Skins.Garf?Face=SGirlSkins.Isis?Voice=BotPack.Voic eFemaleTwo?OverrideClass=?Game=Botpack.CTFGame?Mut ator=AntiAimCheatV1_2.AntiAimCheat
Base Mutator is CTF-Thorns.DMMutator0
Mutators AntiAimCheatV1_2.AntiAimCheat
Add mutator AntiAimCheatV1_2.AntiAimCheat

Crsk
06-08-2013, 05:51 AM
the mutator is located at "AntiAimCheatV1_2.AntiAimController", why you have "AntiAimCheatV1_2.AntiAimCheat" ?

~V~
06-08-2013, 07:35 AM
Ooops :D

Ok works fine now. Thanks.

Had to change mouse sens from 8 to 40 so I could do 180s, but it works ok I think.

--- Updated ---

Oh. It works apart from I didn't hear any sound when I pressed CV

EDIT: yes there is a sound but it is much quieter than the sound of my death. I suggest testing PlayOwnedSound instead of PlaySound as it's usually louder.

SAM
06-08-2013, 12:33 PM
Crsk shall we wait for an update as per above suggestion or OK to go?

~V~
06-08-2013, 03:26 PM
Hmm not sure if PlayOwnedSound() is the one that plays loudest after all. Been out the loop a bit...

Higor
06-08-2013, 03:35 PM
Just play around with the Volume parameter in PlaySound()

Crsk
06-08-2013, 06:29 PM
Had to change mouse sens from 8 to 40 so I could do 180s, but it works ok I think.

yeah, many complaints incoming i guess... but it is needed to avoid the axis cheat until using another method but i don't have it for now.
you need to change your sens only once.

i'll give you in PM the console keybind for the mouse axis cheat if you want to test it.

about the sound problem... i did what Higor said, should be fixed now.

-----

Changes from V1.2 to V1.3

-fix, the robot sound, now plays at the same volume as KillingMessages.
-added, bCVKillWhenCaught configurable in the ini (should be True to avoid allow use CV once, second time is kick from server if bCVWarnBeforeKick is true)
-added, bMLKillWhenCaught configurable in the ini (no need to set it True at all)

Download >> AntiAimCheatV1.3 (http://www.mediafire.com/download/020wr5i9z4t4yjn/AntiAimCheatV1_3.rar)

~V~
06-13-2013, 11:46 AM
Sam, could you please install this? I still can't get in server.

SAM
06-13-2013, 05:34 PM
I'm sorry I forgot about this. I will bed this tomorrow. If someone can bump that would be helpful.

Chamberly
06-13-2013, 05:49 PM
I'm sorry I forgot about this. I will bed this tomorrow. If someone can bump that would be helpful.

Bumpy! "bed this tomorrow"...? xD

~V~
06-13-2013, 06:14 PM
"bed this tomorrow"...? xD

Who knows what he means ;)

SAM
06-14-2013, 02:22 PM
lol...auto correct on phone. Add*

mackle
09-23-2014, 01:15 PM
I am also having this problem playing on your servers using UT linux native.
UT crashes when using padsp (PulseAudio OSS Wrapper) to enable sound, with:

Signal: SIGIOT [iot trap]
Aborting.

It will however play on other servers.